Tricks Computer

Excel: convertire Date in Testo


Hai dei dati in formato Data e vuoi trasformarli in Testo? Se provi a trasformare il formato della cella da Data a Testo ti viene mostrato un valore strano… idem se copi il valore della cella della data e lo incolli in una nuova cella. Allora? Sei prigioniero del formato Data? Ovvio che no. 
 
Posizionati nella cella dove vuoi ottenere il risultato, ovvero la tua data in formato testo e, ponendo che ti abbia la data originale nella cella A1, scrivi questa formula 
 
=TESTO(A1;"GGMMAAAA") 
 
che significa letteralmente "Trasforma in testo il dato che trovi nella cella A1 e scrivimelo nel formato GGMMAAAA" (giorno mese anno). 
 
Tutto qui, o quasi. Puoi modificare il formato del risultato finale come vuoi tu, ad esempio: 
 
=TESTO(A1;"AAAA") ti restituisce solo l'anno
=TESTO(A1;"AAAAMMGG") ti restituisce la data, in formato Testo, ma con l'ordine anno mese giorno
=TESTO(A1;"GG-MM-AAAA") inserisce i trattini tra giorno-mese-anno 
 
e così via, puoi fare tutte le prove che vuoi. 
 
Attento: hai ua versione inglese di Excel? Devi sapere che le formule sono tradotte e devi usare =TEXT(A1;"DDMMYYYY") anzichè =TESTO(A1;"GGMMAAAA"). Ma non è finita qui. Se ancora non funziona, prova con =TEXT(A1;"GGMMAAAA"), ovvero formula in inglese e dati in italiano. 
 
Fatto!

Articoli correlati

Nessun contenuto disponibile
Lascia un commento